加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU 1865(大数)

发布时间:2020-12-14 02:35:19 所属栏目:大数据 来源:网络整理
导读:1sting Time Limit: 5000/1000 MS (Java/Others) ? ?Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4020 ? ?Accepted Submission(s): 1493 Problem Description You will be given a string which only contains ‘1’; You can merge tw
1sting
Time Limit: 5000/1000 MS (Java/Others) ? ?Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4020 ? ?Accepted Submission(s): 1493
Problem Description

You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’,or leave the ‘1’ there. Surly,you may get many different results. For example,given 1111,you can get 1111,121,112,211,22. Now,your work is to find the total number of result you can get.


Input

The first line is a number n refers to the number of test cases. Then n lines follows,each line has a string made up of ‘1’ . The maximum length of the sequence is 200.


Output

The output contain n lines,each line output the number of result you can get .


Sample Input

3
1
11
22222


Sample Output

1
2

8

//斐波那契数列加大数  正常的斐波那契秩只需一维数组,由于位数太多只能用二维数组来模拟
#include <stdio.h>
#include <string.h>
int str1[210][300]={{0}};
int main()
{
    int n;
    scanf("%d",&n);
    getchar();
    while(n--)
    {
        char str[300];
        gets(str);
        int len=strlen(str);
        str1[0][0]=1;
        str1[1][0]=2;
        for(int i=2;i<len;i++)
        {
            int c=0,k;
            for(k=0;k<300;k++)
            {
                int s=str1[i-1][k]+str1[i-2][k]+c;
                str1[i][k]=s%10;
                c=s/10;
            }
            while(c)
            {
                str1[i][k++]=c%10;
                c/=10;
            }
        }
        int i;
        for(i=299;i>=0;i--)  //判断是否为零
            if(str1[len-1][i])
                break;
        for(int j=i;j>=0;j--)
            printf("%d",str1[len-1][j]);
        printf("n");
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读