加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

POJ 题目2506Tiling(大数)

发布时间:2020-12-14 02:28:00 所属栏目:大数据 来源:网络整理
导读:Tiling Time Limit: ?1000MS ? Memory Limit: ?65536K Total Submissions: ?8128 ? Accepted: ?3941 Description In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?? Here is a sample tiling of a 2x17 rectangle.? Input Input is a se
Tiling
Time Limit:?1000MS ? Memory Limit:?65536K
Total Submissions:?8128 ? Accepted:?3941

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles??
Here is a sample tiling of a 2x17 rectangle.?


Input

Input is a sequence of lines,each line containing an integer number 0 <= n <= 250.

Output

For each line of input,output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.?

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

Source

The UofA Local 2000.10.14

公式a[n]=a[n-1]+a[n-2]*2

ac代码

#include<stdio.h>
#include<string.h>
int str[255][100];
void fun()
{
	str[0][0]=1;
	str[1][0]=1;
	str[2][0]=3;
	int temp,i,j;
	temp=0;
	for(i=3;i<=250;i++)
	{
		for(j=0;j<100;j++)
		{
			temp+=(str[i-2][j])*2+str[i-1][j];
			str[i][j]=temp%10;
			temp/=10;
		}
	}
}
int main()
{
	fun();
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int i;
		for(i=99;i>=0;i--)
		{
			if(str[n][i]!=0)
				break;
		}
		for(;i>=0;i--)
		{
			printf("%d",str[n][i]);
		}
		printf("n");
	}	
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读