加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDOJ 1047 Integer Inquiry(多次大数相加)

发布时间:2020-12-14 02:27:50 所属栏目:大数据 来源:网络整理
导读:Integer Inquiry Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 15140????Accepted Submission(s): 3889 Problem Description One of the first users of BIT's new supercomputer was Chip D

Integer Inquiry

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15140????Accepted Submission(s): 3889


Problem Description
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment,once one became available on the third floor of the Lemon Sky apartments on Third Street.)
?

Input
The input will consist of at most 100 lines of text,each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length,and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.
?

Output
Your program should output the sum of the VeryLongIntegers given in the input.


This problem contains multiple test cases!

The first line of a multiple input is an integer N,then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
?

Sample Input
  
  
1 123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0
?

Sample Output
  
  
370370367037037036703703703670
?

?

?

不知道是题目描述太模糊,还是我英语太差,半天没看懂。题意是:输出一个n,表示有n组测试数据,每组测试数据由多个长度不大于100的大数组成,每组测试数据由0结束,求这些大数相加之和。每组输出结果与下组输入实例之间空一行。

典型的大数题,很简单,大数A+B的变形,注意格式,及00+00的情况就好

代码如下:

?

#include<cstdio>
#include<cstring>
int a[110];
char s[110],str[110];
void add(char s[],int a[])
{
	int b[110],i,len,j;
	memset(b,sizeof(b));
	len=strlen(s);
	for(i=0;i<len;i++)
	   b[len-i-1]=s[i]-'0';
	for(i=0;i<len;i++)
	{
		a[i]+=b[i];
		if(a[i]>9)
		{
			a[i+1]++;
			a[i]-=10;
		}
	}
}

int main()
{
	int n,j;
	scanf("%d",&n);
	while(n--)
	{
		memset(a,sizeof(a));
		while(scanf("%s",&str)&&strcmp(str,"0")!=0)
			add(str,a);
		for(i=110;i>0;i--)//此处i!=0,防止出现结果为0,要输出0的情况 
		  if(a[i])
		    break;
		for(;i>=0;i--)
		   printf("%d",a[i]);
		printf("n");
		if(n)
		  printf("n");
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读