加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDOJ 1002 A + B Problem II(大数相加)

发布时间:2020-12-14 02:27:40 所属栏目:大数据 来源:网络整理
导读:A + B Problem II Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 260764????Accepted Submission(s): 50425 Problem Description I have a very simple problem for you. Given two integers

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 260764????Accepted Submission(s): 50425


Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
?

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
?

Output
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
?

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
?

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 2222222222222221110
?

输出格式一定注意

ac代码:

#include<stdio.h>  
#include<string.h>  
int main()  
{  
    char str1[1002],str2[1002];  
    int c,i,j,n,m,s1[1002],s2[1002],len1,len2,count;  
    count=1;  
    scanf("%d",&n);  
    m=n;  
    while(m--)  
    {  
        memset(s1,1002*sizeof(int));  
        memset(s2,1002*sizeof(int));  
        scanf("%s",str1);  
        scanf("%s",str2);  
        len1=strlen(str1);  
        len2=strlen(str2);  
        c=0;  
        for(i=len1-1;i>=0;i--)  
            s1[c++]=str1[i]-'0';  
        c=0;  
        for(i=len2-1;i>=0;i--)  
            s2[c++]=str2[i]-'0';  
        for(i=0;i<1002;i++)  
        {  
            s1[i]+=s2[i];  
            if(s1[i]>=10)  
            {  
                s1[i]-=10;  
                s1[i+1]++;  
            }  
        }  
        printf("Case %d:n",count++);  
        printf("%s + %s = ",str1,str2);  
        for(i=1001;i>=0;i--)  
            if(s1[i])  
                break;  
        for(j=i;j>=0;j--)  
            printf("%d",s1[j]);  
        printf("n");  
        if(count!=n+1)  
            printf("n");  
    }  
    return 0;  
}  

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读