加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU 1002--A + B Problem II【大数】

发布时间:2020-12-14 02:27:32 所属栏目:大数据 来源:网络整理
导读:A + B Problem II Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 261047????Accepted Submission(s): 50505 Problem Description I have a very simple problem for you. Given two integers

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 261047????Accepted Submission(s): 50505


Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
?

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
?

Output
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
?

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
?

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 2222222222222221110
?
跟着大一刷水题。

#include <cstdio>
#include <cstring>

int a[11000];
int b[11000];
char str1[11000];
char str2[11000];

int main (){
	int T;
	int d = 1;
	scanf("%d",&T);
	while(T--){
		if(d > 1)
			printf("n");
		printf("Case %d:n",d++);
		memset(a,sizeof(a));
		memset(b,sizeof(b));
		scanf("%s%s",str1,str2);
		printf("%s + %s = ",str2);
		int len1 = strlen(str1);
		int len2 = strlen(str2);
		int j,i,k;
		for(j = 0,i = len1 - 1; i >= 0; i--)
			a[j++] = str1[i] - '0';
		for(k = 0,i = len2 - 1; i >= 0; i--)
			b[k++] = str2[i] - '0';
		if(k < j)
			k = j;
		for(int i = 0; i < k; ++i){
			a[i] +=b[i];
			if(a[i] > 9){
				a[i] = a[i] % 10;
				a[i + 1]++;
			}
		}
		for(i = k; !a[i] && i >= 0; i--);
		for(; i >= 0; i--)
			printf("%d",a[i]);
		printf("n"); 
	} 
	return 0;
} 

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读