加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

hd1002

发布时间:2020-12-14 02:27:26 所属栏目:大数据 来源:网络整理
导读:A + B Problem II Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Problem Description I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B. ? Input Th

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)

Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
?
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
?
Output
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
?
Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
?

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 2222222222222221110
?
题目大意就是大数相加
#include<stdio.h>
#include<string.h>
int main()
{
	int n,i,j,k,t,lena,lenb,a[1001],b[1001],sum[1001];
	char sa[1001],sb[1001];
	scanf("%d",&n);
	for(k=1;k<=n;++k)
	{
		printf("Case %d:n",k);
		memset(a,sizeof(a));
		memset(b,sizeof(b));
		memset(sum,sizeof(sum));
		scanf("%s %s",sa,sb);
		lena=strlen(sa);
		lenb=strlen(sb);
		for(i=lena-1,j=0;i>=0;j++,i--)a[j]=sa[i]-'0';
		for(i=lenb-1,i--)b[j]=sb[i]-'0';
		for(i=0;i<1001;++i)
		{
			sum[i]=sum[i]+a[i]+b[i];
			if(sum[i]>=10)
			{
				sum[i]-=10;
				sum[i+1]+=1;
			}
		}
		printf("%s + %s = ",sb);
		i=1000;
		while(sum[i]==0&&i>=0)i--;
		for(;i>=0;i--)printf("%d",sum[i]);
		printf("n");
		if(k!=n)printf("n");
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读