加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

NUMBER BASE CONVERSION(大数进制转换)

发布时间:2020-12-14 02:27:20 所属栏目:大数据 来源:网络整理
导读:NUMBER BASE CONVERSION Time Limit: ?1000MS ? Memory Limit: ?10000K Total Submissions: ?4580 ? Accepted: ?2095 Description Write a program to convert numbers in one base to numbers in a second base. There are 62 different digits:? { 0-9,A-Z
NUMBER BASE CONVERSION
Time Limit:?1000MS ? Memory Limit:?10000K
Total Submissions:?4580 ? Accepted:?2095

Description

Write a program to convert numbers in one base to numbers in a second base. There are 62 different digits:?
{ 0-9,A-Z,a-z }?
HINT: If you make a sequence of base conversions using the output of one conversion as the input to the next,when you get back to the original base,you should get the original number.?

Input

The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines will have a (decimal) input base followed by a (decimal) output base followed by a number expressed in the input base. Both the input base and the output base will be in the range from 2 to 62. That is (in decimal) A = 10,B = 11,...,Z = 35,a = 36,b = 37,z = 61 (0-9 have their usual meanings).?

Output

The output of the program should consist of three lines of output for each base conversion performed. The first line should be the input base in decimal followed by a space then the input number (as given expressed in the input base). The second output line should be the output base followed by a space then the input number (as expressed in the output base). The third output line is blank.?

Sample Input

8
62 2 abcdefghiz
10 16 1234567890123456789012345678901234567890
16 35 3A0C92075C0DBF3B8ACBC5F96CE3F0AD2
35 23 333YMHOUE8JPLT7OX6K9FYCQ8A
23 49 946B9AA02MI37E3D3MMJ4G7BL2F05
49 61 1VbDkSIMJL3JjRgAdlUfcaWj
61 5 dl9MDSWqwHjDnToKcsWE1S
5 10 42104444441001414401221302402201233340311104212022133030

Sample Output

62 abcdefghiz
2 11011100000100010222220010010110022222001001100011010010001

10 1234567890123456789012345678901234567890
16 3A0C92075C0DBF3B8ACBC5F96CE3F0AD2

16 3A0C92075C0DBF3B8ACBC5F96CE3F0AD2
35 333YMHOUE8JPLT7OX6K9FYCQ8A

35 333YMHOUE8JPLT7OX6K9FYCQ8A
23 946B9AA02MI37E3D3MMJ4G7BL2F05

23 946B9AA02MI37E3D3MMJ4G7BL2F05
49 1VbDkSIMJL3JjRgAdlUfcaWj

49 1VbDkSIMJL3JjRgAdlUfcaWj
61 dl9MDSWqwHjDnToKcsWE1S

61 dl9MDSWqwHjDnToKcsWE1S
5 42104444441001414401221302402201233340311104212022133030

5 42104444441001414401221302402201233340311104212022133030
10 1234567890123456789012345678901234567890

Source

Greater New York 2002


#include<cstdio>
#include<iostream>
#include<cstring>
const int maxn=1000;
using namespace std;
int t[maxn],A[maxn];
char str1[maxn],str2[maxn];
int n,m;
void solve(char *str1,char *str2,int n,int m)
{
    int i,len,k;
    len=strlen(str1);
    for(i=len;i>=0;i--)
    {
        t[len-1-i]=str1[i]-(str1[i]<58?48:str1[i]<97?55:61);
    }
    for(k=0;len;)
    {
        for(i=len;i>=1;i--)
        {
            t[i-1]+=t[i]%m*n;
            t[i]/=m;
        }
        A[k++]=t[0]%m;
        t[0]/=m;
        while(len>0&&!t[len-1])
        {
            len--;
         }
    }
    str2[k]=NULL;
    for(i=0;i<k;i++)
    {
        str2[k-1-i]=A[i]+(A[i]<10?48:A[i]<36?55:61);
    }
}
int main()
{
    int T,i;
    cin>>T;
    for(i=1;i<=T;i++)
    {
        cin>>n>>m>>str1;
        solve(str1,str2,n,m);
        cout<<n<<" "<<str1<<endl;
        cout<<m<<" "<<str2<<endl;
        if(i!=T)
        {
            cout<<endl;
        }
    }
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读