加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDOJ 1013 Digital Roots(大数)

发布时间:2020-12-14 02:27:07 所属栏目:大数据 来源:网络整理
导读:Digital Roots Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 58524????Accepted Submission(s): 18278 Problem Description The digital root of a positive integer is found by summing th

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 58524????Accepted Submission(s): 18278


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits,those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example,consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit,6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit,the process must be repeated. Adding the 1 and the 2 yeilds 3,a single digit and also the digital root of 39.
?

Input
The input file will contain a list of positive integers,one per line. The end of the input will be indicated by an integer value of zero.
?

Output
For each integer in the input,output its digital root on a separate line of the output.
?

Sample Input
  
  
24 39 0
?

Sample Output
  
  
6 3
?

Source
Greater New York 2000
?

Recommend
We have carefully selected several similar problems for you:?? 1017? 1012? 1018? 1048? 1016

就是一个大数求和问题,我竟然。。。
第一次用整型,WA了
第二次没初始化,WA了
第三次AC:

#include<stdio.h>
#include<string.h>
int main(){
	char a[10000];
	int la,b[10000],sum,i;
	while(scanf("%s",a)&&strcmp(a,"0")!=0){
		la=strlen(a);
		sum=0;//各位数和 
		for(i=0;i<la;i++){
			b[i]=a[i]-'0';//字符转数字 
			sum+=b[i];//一个个求和 
			if(sum>=10)//超过10,最多18 
			sum=sum%10+sum/10;//两位数再加起来 
		}
		printf("%dn",sum);
		memset(a,sizeof(a));
		memset(b,sizeof(b));
	}
	return 0;
}
?

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读