加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDOJ 1250 Hat's Fibonacci(大数,错了11次!!)

发布时间:2020-12-14 02:26:43 所属栏目:大数据 来源:网络整理
导读:Hat's Fibonacci Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9103????Accepted Submission(s): 2953 Problem Description A Fibonacci sequence is calculated by adding the previous two

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9103????Accepted Submission(s): 2953


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence,with the first two members being both 1.
F(1) = 1,F(2) = 1,F(3) = 1,F(4) = 1,F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input,and print that Fibonacci number.
?

Input
Each line will contain an integers. Process to end of file.
?

Output
For each case,output the result in a line.
?

Sample Input
  
  
100
?

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data,ie. F(20) = 66526 has 5 digits.
?


?

神题,各种超RT,各种运行超限。。。

?

题目没有直接给出n的最大值,只给出了数列中最大数长度不超过2005,据大牛测试n为7060时,长度为2012。这样就知道数组长度

至少为7060。然而并没有什么乱用,常规做法还是会超限。 这里可以用数组的每一个纵向下标储存4位数解决超限问题。

?

上代码:

?

#include<cstdio>
#define num 8000
#define max 510
int a[num][max];

void fib()
{
	int i,j,c,s;
	a[1][max-1]=a[2][max-1]=a[3][max-1]=a[4][max-1]=1;
	for(i=5;i<num;i++)
	{
		c=0;
		for(j=max-1;j>=0;j--)
		{
			s=a[i][j]+a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j]+c;
			a[i][j]=s%10000;
			c=s/10000;
		}
	}
}

int main()
{
	fib();
	int n,i;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<max;i++)
		   if(a[n][i]!=0)
		      break;
		printf("%d",a[n][i]);
		i++;
		for(;i<max;i++)
		   printf("%04d",a[n][i]);
		printf("n");
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读