加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

杭电1250Hat's Fibonacci

发布时间:2020-12-14 02:25:57 所属栏目:大数据 来源:网络整理
导读:Hat's Fibonacci Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9134????Accepted Submission(s): 2970 Problem Description A Fibonacci sequence is calculated by adding the previous two

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9134????Accepted Submission(s): 2970


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence,with the first two members being both 1.
F(1) = 1,F(2) = 1,F(3) = 1,F(4) = 1,F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input,and print that Fibonacci number.
?

Input
Each line will contain an integers. Process to end of file.
?

Output
For each case,output the result in a line.
?

Sample Input
  
  
100
?

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data,ie. F(20) = 66526 has 5 digits.
?

Author

妥妥的水题,但是要是存二维数组,第二维只存一位数的话会超内存的,超了3次才想到存4位数;所以第二维只需要开到2005/4即可;一维开到8000即可.

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 2010
int a[7061][555];
int i,n,m,j,k,l;
int main()
{
	memset(a,sizeof(a));
	 a[1][0]=a[2][0]=a[3][0]=a[0][0]=1;
	 for(i=4;i<7060;i++)
	 {
	 	k=0;
	 	for(j=0;j<555;j++)
	 	{
	 		a[i][j]=a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j]+k;
	 		k=a[i][j]/10000;
	 		a[i][j]=a[i][j]%10000;
		 }
	 }
	 while(scanf("%d",&n)!=EOF)
	 {
	 	j=550;
	 	while(a[n-1][j]==0)
		j--;
		printf("%d",a[n-1][j--]);//这一位不一定是四位数,所以输出%d 
		for(; j>=0; j--)
		printf("%04d",a[n-1][j]);//剩下的一定是4位数的,所以输出%04d,否则就会错.!!!!!! 
		putchar('n');
		//printf("%d",a[n-1][j]);//这的输出也是ac代码; 
		//i=j-1;//个人比较喜欢下边的输出 
		//for(i=j-1;i>=0;i--)
		//printf("%04d",a[n-1][i]);
		//printf("n"); 
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读