加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

poj2109Power of Cryptography 大数开根

发布时间:2020-12-14 02:25:51 所属栏目:大数据 来源:网络整理
导读:Power of Cryptography Time Limit: 1000MS ? Memory Limit: 30000K Total Submissions: 20679 ? Accepted: 10468 Description Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among the
Power of Cryptography
Time Limit: 1000MS ? Memory Limit: 30000K
Total Submissions: 20679 ? Accepted: 10468

Description

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest.
This problem involves the efficient computation of integer roots of numbers.
Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem,given such integers n and p,p will always be of the form k to the n th. power,for an integer k (this integer is what your program must find).

Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200,1<=p<10 101 and there exists an integer k,1<=k<=10 9 such that k n = p.

Output

For each integer pair n and p the value k should be printed,i.e.,the number k such that k n =p.

Sample Input

2 16
3 27
7 4357186184021382204544

Sample Output

4
3
1234

Source

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>

using namespace std;

int main()
{
	double m;
	int n;
	while(cin>>n>>m)
	{
		printf("%gn",pow(m,1.0/n));
       //n^a=m->pow(n,a)=m->pow(m,1.0/n)=a;
	}//cout<<pow(p,1.0/n);  //指数的倒数就是开n次方
}
/*二分+高精
#include<iostream>
#include<stdio.h>
#include<math.h>
#define eps 0.0000000001

using namespace std;

double n,m,k;
void work()
{
    long long left,right,mid;
    left = 0;
    right = 1000000002;
    while(left + eps < right)
    {
        mid = (left + right) / 2;
        if(pow(mid,n)-m > 0)
            right = mid;
        else if(pow(mid,n) - m < 0)
            left = mid;
        else
        {
            printf("%.0ldn",mid) ;
            break;
        }
    }
}
int main()
{
    while(cin>>n>>m)
        work();
    return 0;
}
*/

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读