加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

(POJ2635)The Embarrassed Cryptographer(大数取模)

发布时间:2020-12-14 02:23:47 所属栏目:大数据 来源:网络整理
导读:The Embarrassed Cryptographer Time Limit: 2000MS Memory Limit: 65536K Total Submissions: 13041 Accepted: 3516 Description The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousa

The Embarrassed Cryptographer
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13041 Accepted: 3516

Description
The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users,which is now in use in his company. The cryptographic keys are created from the product of two primes,and are believed to be secure because there is no known method for factoring such a product effectively.
What Odd Even did not think of,was that both factors in a key should be large,not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired,Odd Even secretly goes through all the users keys,to check if they are strong enough. He uses his very poweful Atari,and is especially careful when checking his boss’ key.

Input
The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10100 and 2 <= L <= 106. K is the key itself,a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.

Output
For each number K,if one of its factors are strictly less than the required L,your program should output “BAD p”,where p is the smallest factor in K. Otherwise,it should output “GOOD”. Cases should be separated by a line-break.

Sample Input

143 10
143 20
667 20
667 30
2573 30
2573 40
0 0

Sample Output

GOOD
BAD 11
GOOD
BAD 23
GOOD
BAD 31

Source
Nordic 2005
判断所给的数是不是存在小于L的质因子;
思路:大数取模,

#include <set>
#include <map>
#include <list>
#include <stack>
#include <cmath>
#include <queue>
#include <string>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#define PI cos(-1.0)
#define RR freopen("input.txt","r",stdin)
using namespace std;
typedef long long LL;
const int MAX = 1e6+100;
int Arr[100000];
int top;
bool vis[MAX];
char str[110];
int b[40];
int L;
bool flag;
int main()
{
    memset(vis,false,sizeof(vis));
    top=0;
    for(LL i=2;i<MAX;i++)
    {
        if(!vis[i])
        {
            Arr[top++]=i;
            for(LL j=i*i;j<MAX;j+=i)
            {
                vis[j]=true;
            }
        }
    }
    while(scanf("%s %d",str,&L))
    {
        if(str[0]=='0'&&L==0)
        {
            break;
        }
        flag=false;
        int len=strlen(str);
        int l=0;
        for(int i=len-1;i>=0;i-=3)
        {
            int ans=0;
            for(int j=2;j>=0;j--)
            {
                if(i-j<0)
                {
                    continue;
                }
                ans=(ans*10+str[i-j]-'0');
            }
            b[l++]=ans;
        }
        int ans;
        for(int i=0;Arr[i]<L;i++)
        {
            ans=0;
            for(int j=l-1;j>=0;j--)
            {
                ans=(ans*1000+b[j])%Arr[i];
            }
            if(ans==0)
            {
                cout<<"BAD "<<Arr[i]<<endl;
                flag=true;
                break;
            }
        }
        if(!flag)
        {
            cout<<"GOOD"<<endl;
        }
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读