加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

杭电1018-Big Number(大数)

发布时间:2020-12-14 02:23:40 所属栏目:大数据 来源:网络整理
导读:Big Number Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 31165????Accepted Submission(s): 14464 Problem Description In many applications very large integers numbers are required. S

Big Number

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31165????Accepted Submission(s): 14464


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data,encryption,etc. In this problem you are given a number,you have to determine the number of digits in the factorial of the number.
?

Input
Input consists of several lines of integer numbers. The first line contains an integer n,which is the number of cases to be tested,followed by n lines,one integer 1 ≤ n ≤ 10 7?on each line.
?

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
?

Sample Input
  
  
2 10 20
?

Sample Output
  
  
7 19
?

? ? ? ? ?还记得那个神奇的 斯塔林公式吗?


? ? ? ? ?直接就是公式了!


#include<cstdio>
#include<cstring>
#include<cmath>
#define pi acos(-1.0)
using namespace std;
int n;
int solve()
{
	return (int)((n*log(n)-n+(log(2*pi*n))/2)/log(10))+1;
}
int main()
{
	int N;
	scanf("%d",&N);
	while(N--)
	{
		scanf("%d",&n);
		int t=solve();
		printf("%dn",t);
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读