加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

杭电1002-A + B Problem II(大数)

发布时间:2020-12-14 02:20:00 所属栏目:大数据 来源:网络整理
导读:A + B Problem II Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 269506????Accepted Submission(s): 52064 Problem Description I have a very simple problem for you. Given two integers

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 269506????Accepted Submission(s): 52064


Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
?

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
?

Output
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
?

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
?

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 2222222222222221110
?


大数相加,挺简单的 ,有一点格式要注意下,每两个测试数据中间要有一个空行,注意!



#include<cstdio>
#include<cstring>
char s1[1000],s2[1000];
int a[1000],b[1000];
int main()
{
	int N,len1,len2,t,i,cot=1;
	scanf("%d",&N);
	while(N--)
	{
		memset(a,sizeof(a));
		memset(b,sizeof(b));
		if(cot!=1)
		printf("n"); 
		scanf("%s%s",s1,s2);
		printf("Case %d:n",cot++);	
		len1=strlen(s1);
		len2=strlen(s2);
		t=0;
		for(i=len1-1;i>=0;i--)
		a[t++]=s1[i]-'0';
		t=0;
		for(i=len2-1;i>=0;i--)
		b[t++]=s2[i]-'0';//字符型转化为整形,进行计算
		if(len1<len2)
		{
			t=len2;
			len1=len2;
			len2=t;
		 } 
		for(i=0;i<len1;i++)
		{
			a[i]+=b[i];//按位相加
			if(a[i]>9)//判断是否进位
			{
				a[i+1]++;
				a[i]-=10; 
			}
		}
		for(i=999;a[i]==0;i--);
		printf("%s + %s = ",s2); 
		for(;i>=0;i--)
		printf("%d",a[i]);
		printf("n");  
	}
	return 0;
} 

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读