加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

hdoj 2674 N!Again

发布时间:2020-12-14 02:19:33 所属栏目:大数据 来源:网络整理
导读:N!Again Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4152????Accepted Submission(s): 2232 Problem Description WhereIsHeroFrom: ????????????Zty,what are you doing ? Zty: ?????????

N!Again

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4152????Accepted Submission(s): 2232


Problem Description
WhereIsHeroFrom: ????????????Zty,what are you doing ?
Zty: ????????????????????????????????????I want to calculate N!......
WhereIsHeroFrom: ????????????So easy! How big N is ?
Zty:????????????????????????????????????1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom: ????????????Oh! You must be crazy! Are you Fa Shao?
Zty: ????????????????????????????????????No. I haven's finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1,N! = N*(N-1)!
?

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
?

Output
For each case,output N! mod 2009
?

Sample Input
  
  
4 5
?

Sample Output
  
  
24 120
?题意: 2009 =7*7*41,所以输入超过41的数取余后得到0,输入0,时输出1;
???????????? 对于小于41的同余定理求,即可!
??代码:
??????
#include<stdio.h>
int main()
{
	int i,j,n;
	char s[1010];
	while(scanf("%d",&n)!=EOF)
	{
		if(n>41)
		printf("0n");
		else if(n==0)
		printf("1n");
		else if(n<=41)
		{
			int sum=1;
			for(i=1;i<=n;i++)
			 {
			 	sum=(sum*(i%2009))%2009;
			 }
			 printf("%dn",sum);
		}
	}
	return 0;
} 
 

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读