加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

hdu1047Integer Inquiry(大数相加)

发布时间:2020-12-14 02:11:51 所属栏目:大数据 来源:网络整理
导读:Integer Inquiry Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 16405????Accepted Submission(s): 4240 Problem Description One of the first users of BIT's new supercomputer was Chip D

Integer Inquiry

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16405????Accepted Submission(s): 4240


Problem Description
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment,once one became available on the third floor of the Lemon Sky apartments on Third Street.)
?

Input
The input will consist of at most 100 lines of text,each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length,and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.
?

Output
Your program should output the sum of the VeryLongIntegers given in the input.


This problem contains multiple test cases!

The first line of a multiple input is an integer N,then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
?

Sample Input
  
  
1 123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0
?

Sample Output
  
  
370370367037037036703703703670
?题意:这次不是两个大数相加,而是多个大数相加;其实都一样,解题思路还每次按两个大数的相加的方法进行计算,每次将计算得到的值存到一个的固定的数组里,
最后相加完后就是结果啦。需要注意格式啊;
AC代码:
#include<stdio.h>
#include<string.h>
int main()
{
	char b[120];
	int x[10010],y[1100],n,i,j,k;
	int len;
	scanf("%d",&n);
	while(n--)
	{
		memset(x,sizeof(x));
		memset(b,sizeof(b));
		while(scanf("%s",b))
		{
			if(b[0]=='0') break;
			memset(y,sizeof(y));  
		   	len=strlen(b);
		   	for(i=len-1,k=0;i>=0;i--)
		   	{
		   	  y[k++]=b[i]-'0';   
			}
			for(i=0;i<1010;i++)
			{
				x[i]+=y[i];
				if(x[i]>=10)
				{
					x[i]-=10;
					x[i+1]++;
				}
			 } 
		}
	for(i=1000;i>=0;i--)
	{
		if(x[i]>0) break;
	}
	if(i<0) printf("0n");
	else
	{
	for(j=i;j>=0;j--)
	 printf("%d",x[j]);
	printf("n");
    }
    if(n!=0)
     printf("n");
	}
return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读