加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

1024. Palindromic Number (25)【简易大数加法+回文】——PAT (A

发布时间:2020-12-14 02:11:25 所属栏目:大数据 来源:网络整理
导读:题目信息 1024. Palindromic Number (25) 时间限制400 ms 内存限制65536 kB 代码长度限制16000 B A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example,1234321 is a palindromic numbe

题目信息

1024. Palindromic Number (25)

时间限制400 ms
内存限制65536 kB
代码长度限制16000 B

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example,1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First,the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number,this is repeated until it gives a palindromic number. For example,if we start from 67,we can obtain a palindromic number in 2 steps: 67 + 76 = 143,and 143 + 341 = 484.

Given any positive integer N,you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K,where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case,output two numbers,one in each line. The first number is the paired palindromic number of N,and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps,just output the number obtained at the Kth step and K instead.

Sample Input 1:
67 3
Sample Output 1:
484
2
Sample Input 2:
69 3
Sample Output 2:
1353
3

解题思路

字符串模拟加法,reverse用来判定回文

AC代码

#include <cstdio>
#include <vector>
#include <algorithm>
#include <iostream>
#include <string>
using namespace std;

string add(string a,string b){
    char s[1002] = {0};
    s[1001] = '';
    int loc = 1000;
    for (int i = a.size() - 1; i >= 0; --i,--loc){
        s[loc] += a[i] - '0' + b[i] - '0';
        if (s[loc] >= 10){
            ++s[loc-1];
            s[loc] -= 10;
        }
        s[loc] += '0';
    }
    if (s[loc] > 0) {
        s[loc] += '0';
        --loc;
    }
    return string(s + loc + 1);
}
int main()
{
    string s;
    int k;
    cin >> s >> k;
    int cnt = 0;
    while (++cnt <= k){
        string ts = s;
        reverse(ts.begin(),ts.end());
        if (s == ts){
            cout << s << endl << cnt - 1 << endl;
            break;
        }else{
            s = add(s,ts);
        }
    }
    if (cnt > k) cout << s << endl << k << endl;
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读