加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

杭电-2674N!Again(大数阶乘)

发布时间:2020-12-14 02:11:00 所属栏目:大数据 来源:网络整理
导读:N!Again Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4267????Accepted Submission(s): 2279 Problem Description WhereIsHeroFrom: ????????????Zty,what are you doing ? Zty: ?????????

N!Again

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4267????Accepted Submission(s): 2279


Problem Description
WhereIsHeroFrom: ????????????Zty,what are you doing ?
Zty: ????????????????????????????????????I want to calculate N!......
WhereIsHeroFrom: ????????????So easy! How big N is ?
Zty:????????????????????????????????????1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom: ????????????Oh! You must be crazy! Are you Fa Shao?
Zty: ????????????????????????????????????No. I haven's finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1,N! = N*(N-1)!
?

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
?

Output
For each case,output N! mod 2009
?

Sample Input
  
  
4 5
?

Sample Output
  
  
24 120
?


大数阶乘,但是规律是41及其以后取余2009都为0,一定要优化这一句,否则超时



#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
long long solve(long long  n)
{
	long long t=1;
	for(long long i=n;i>=2;i--)
		t=i*t%2009;
	return t;
}
int main()
{
	long long a,n,i;
	while(scanf("%lld",&n)!=EOF)
	{
		if(n>=41)
		printf("0n");
		else
		{
			a=solve(n);
			printf("%lldn",a);
		}
	}
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读