加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDOJ--1212(大数取余)(Big Number)

发布时间:2020-12-14 02:09:11 所属栏目:大数据 来源:网络整理
导读:HDOJ--1212(大数取余)(Big Number) Big Number Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6540????Accepted Submission(s): 4533 Problem Description As we know,Big Number is always

HDOJ--1212(大数取余)(Big Number)

Big Number

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6540????Accepted Submission(s): 4533


Problem Description
As we know,Big Number is always troublesome. But it's really important in our ACM. And today,your task is to write a program to calculate A mod B.

To make the problem easier,I promise that B will be smaller than 100000.

Is it too hard? No,I work it out in 10 minutes,and my program contains less than 25 lines.
?

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000,and B will be smaller than 100000. Process to the end of file.
?

Output
For each test case,you have to ouput the result of A mod B.
?

Sample Input
  
  
2 3 12 7 152455856554521 3250
?

Sample Output
  
  
2 5 1521

/*这道题不难,就是不好想,这种方法有点巧妙*/

My ? ?solution:

/*2015.12.16*/

#include<stdio.h>
#include<string.h> 
char c[2000];
int main()
{
	int i,j,k,n,m,t;
	while(scanf("%s%d",&c,&n)==2)
	{
		m=0;
		t=strlen(c);
		for(i=0;i<t;i++)//从最高位开始
		{
			m*=10;    //每进一位,余数都要乘10
			m+=c[i]-'0';//把字符转化为数字
			m%=n; 
		}
		printf("%dn",m);
	 } 
	return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读