加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU 1250 Hat's Fibonacci

发布时间:2020-12-14 02:00:46 所属栏目:大数据 来源:网络整理
导读:Hat's Fibonacci Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9821????Accepted Submission(s): 3260 Problem Description A Fibonacci sequence is calculated by adding the previous two

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9821????Accepted Submission(s): 3260


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence,with the first two members being both 1.
F(1) = 1,F(2) = 1,F(3) = 1,F(4) = 1,F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input,and print that Fibonacci number.
?

Input
Each line will contain an integers. Process to end of file.
?

Output
For each case,output the result in a line.
?

Sample Input
  
  
100
?

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data,ie. F(20) = 66526 has 5 digits.

大数题目,用java的大数类写的,代码如下:

import java.math.BigInteger;
import java.util.Scanner;
public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner cin = new Scanner(System.in);
		BigInteger f[]= new BigInteger[10005];
		f[1] = new BigInteger("1");
		f[2] = new BigInteger("1");
		f[3] = new BigInteger("1");
		f[4] = new BigInteger("1");
		for(int i=5;i<=10000;i++)
			f[i]=f[i-1].add(f[i-2].add(f[i-3].add(f[i-4])));
		while(cin.hasNext())
		{
			int n=cin.nextInt();
			System.out.println(f[n]);
		}
	}

}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读