加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

大数深搜

发布时间:2020-12-14 01:50:42 所属栏目:大数据 来源:网络整理
导读:Description Given a positive integer n,write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m contai


Description

Given a positive integer n,write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n,any one of them is acceptable.
Sample Input

2
6
19
0
Sample Output

10 100100100100100100 222222222222222111
#include<iostream>
#include<cstring>
#include<vector>
#include<cstdio>
#include<cstring>
#include<string>
#include<stack>
#include<cmath>
#define inf 0x3f3f3f3f
#define LL unsigned long long
using namespace std;
int n;
bool flag;
void dfs(LL x)
{
    if(x>9999999999999999999||flag)
        return ;
    if(x%n==0)
    {
        cout<<x<<endl;
        flag=1;
        return ;
    }
    dfs(x*10+0);
    dfs(x*10+1);
}
int main()
{
    while(cin>>n)
    {
        if(n==0)
            return 0;
        flag=0;
        dfs(1);
    }
    return 0;
}

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读