加入收藏 | 设为首页 | 会员中心 | 我要投稿 李大同 (https://www.lidatong.com.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 百科 > 正文

【HDU5718 BestCoder 2nd AnniversaryA】【水题 高精度拆数相加

发布时间:2020-12-12 16:15:58 所属栏目:百科 来源:网络整理
导读:Oracle Time Limit: 8000/4000 MS (Java/Others)Memory Limit: 262144/262144 K (Java/Others) Total Submission(s): 536Accepted Submission(s): 232 Problem Description There is once a king and queen,rulers of an unnamed city,who have three daught

Oracle

Time Limit: 8000/4000 MS (Java/Others)Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 536Accepted Submission(s): 232


Problem Description There is once a king and queen,rulers of an unnamed city,who have three daughters of conspicuous beauty.

The youngest and most beautiful is Psyche,whose admirers,neglecting the proper worship of the love goddess Venus,instead pray and make offerings to her. Her father,the king,is desperate to know about her destiny,so he comes to the Delphi Temple to ask for an oracle.

The oracle is an integer n without leading zeroes.

To get the meaning,he needs to rearrange the digits and split the number into <b>two positive integers without leading zeroes</b>,and their sum should be as large as possible.

Help him to work out the maximum sum. It might be impossible to do that. If so,print `Uncertain`.
Input The first line of the input contains an integer T (1T10) ,which denotes the number of test cases.

For each test case,the single line contains an integer n (1n<1010000000) .
Output For each test case,print a positive integer or a string `Uncertain`.
Sample Input
  
  
   
   3
112
233
1
  
  

Sample Output
  
  
   
   22
35
Uncertain


   
    
     
     Hint 
     In the first example,it is optimal to split $ 112 $ into $ 21 $ and $ 1 $,and their sum is $ 21 + 1 = 22 $. In the second example,it is optimal to split $ 233 $ into $ 2 $ and $ 33 $,and their sum is $ 2 + 33 = 35 $. In the third example,it is impossible to split single digit $ 1 $ into two parts. 
   
   
    
  
  

Source BestCoder 2nd Anniversary
Recommend wange2014


#include<stdio.h>
#include<iostream>
#include<string.h>
#include<string>
#include<ctype.h>
#include<math.h>
#include<set>
#include<map>
#include<vector>
#include<queue>
#include<bitset>
#include<algorithm>
#include<time.h>
using namespace std;
void fre() { freopen("c://test//input.in","r",stdin); freopen("c://test//output.out","w",stdout); }
#define MS(x,y) memset(x,y,sizeof(x))
#define MC(x,y) memcpy(x,sizeof(x))
#define MP(x,y) make_pair(x,y)
#define ls o<<1
#define rs o<<1|1
typedef long long LL;
typedef unsigned long long UL;
typedef unsigned int UI;
template <class T1,class T2>inline void gmax(T1 &a,T2 b) { if (b>a)a = b; }
template <class T1,class T2>inline void gmin(T1 &a,T2 b) { if (b<a)a = b; }
const int N = 1e7+10,M = 0,Z = 1e9 + 7,ms63 = 0x3f3f3f3f;
int casenum,casei;
char s[N];
char b[N];
int cnt[10];
int main()
{
	scanf("%d",&casenum);
	for (casei = 1; casei <= casenum; ++casei)
	{
		scanf("%s",s); int n = strlen(s);
		MS(cnt,0);
		for (int i = 0; s[i]; ++i)++cnt[s[i] - 48];
		int no0 = 0;
		for (int i = 1; i <= 9; ++i)no0 += cnt[i];
		if (no0 < 2)puts("Uncertain");
		else
		{
			int plus = 0;
			for (int i = 1; i <= 9; ++i)if (cnt[i])
			{
				--cnt[i];
				plus = i;
				break;
			}
			int m = 0;
			for (int i = 0; i <= 9; ++i)
			{
				while(cnt[i]--)b[m++] = 48 + i;
			}
			b[m] = 0;
			b[0] += plus;
			int p = 0;
			while (b[p] > '9')
			{
				b[p] -= 10;
				++b[p + 1];
				if (b[p + 1] == 1)b[p + 1] += 48;
				++p;
			}
			if (p == m)b[m++] = 0;
			reverse(b,b + m);
			puts(b);
		}
	}
	return 0;
}
/*
【trick&&吐槽】
 用char作为输入输出会快很多

【题意】
给你一个正整数,长度在1e7范围内。
让你把这个正整数拆成2个正整数(无法做到输出Uncertain),使其和尽可能大

【类型】
水题

【分析】
显然,我们使得A尽可能大,使得B为最小正整数,然后求和即可。

【时间复杂度&&优化】
O(Tn)

*/

(编辑:李大同)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读